SMITE XBOX restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This issue has been resolved for SMITE on XBOX, apologies for the inconvenience.
# SMITE
Posted about 2 years ago. Oct 08, 2015 - 22:26 EDT
Investigating
We will be restarting SMITE for XBOX to alleviate Login issues.
Posted about 2 years ago. Oct 08, 2015 - 22:06 EDT