Paladins PC Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 15 days ago. Jun 09, 2018 - 16:56 EDT
Monitoring
Logins have resumed and we are continuing to monitor.
Posted 15 days ago. Jun 09, 2018 - 16:25 EDT
Identified
We are currently experiencing issues with Steam. We are working on the situation.
Posted 15 days ago. Jun 09, 2018 - 16:15 EDT
This incident affected: Paladins (Paladins PC).