Smite PC Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
Brief Data Center Issue #smite
Posted almost 2 years ago. Feb 18, 2016 - 05:49 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted almost 2 years ago. Feb 18, 2016 - 05:40 EST