Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 6 months ago. Jan 17, 2017 - 11:50 EST
Update
We are currently investigating issues with Paladins PC. #Paladins
Posted 6 months ago. Jan 17, 2017 - 11:46 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 6 months ago. Jan 17, 2017 - 11:43 EST
This incident affected: Paladins PC.