Smite is Down
Incident Report for Hi-Rez Studios, Inc
Resolved
Smite is back online #smite
Posted almost 2 years ago. Aug 05, 2015 - 02:22 EDT
Investigating
Smite is currently Down#Smite
Posted almost 2 years ago. Aug 05, 2015 - 02:15 EDT