Hirez Games Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This incident has been resolved. #SMITE #Paladins
Posted 8 months ago. Feb 28, 2017 - 23:13 EST
Investigating
Automated services have detected a possible patcher issue that may impact multiple games. We are investigating. #SMITE #Paladins
Posted 8 months ago. Feb 28, 2017 - 22:40 EST
This incident affected: Smite PC - North America / Europe, Smite Xbox - North America / Europe, Smite PS4 - North America / Europe, Paladins PC, Paladins Xbox, Paladins PS4, Tribes Ascend, and Smite Tactics.