Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Feb 03, 2017 - 20:56 EDT
Identified
We are working to restore match-making services on #Paladins #PC
Posted about 2 months ago. Feb 03, 2017 - 20:34 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 2 months ago. Feb 03, 2017 - 20:30 EDT
This incident affected: Paladins PC.