Pausing logins paladins pc
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins have resumed for #Paladins on #PC
Posted about 2 months ago. Mar 15, 2017 - 11:20 EDT
Identified
We will be pausing logins temporarily for #Paladins on #PC.
Posted about 2 months ago. Mar 15, 2017 - 10:26 EDT
This incident affected: Paladins PC.