Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved#smite
Posted about 1 year ago. Mar 29, 2016 - 12:30 EDT
Update
Users may have problems making purchases, we are investigating#smite
Posted about 1 year ago. Mar 29, 2016 - 10:42 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 1 year ago. Mar 29, 2016 - 10:37 EDT