quick restart of smite xbox
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Dec 30, 2015 - 01:51 EST
Investigating
we are restarting Smite Xbox
#smite
Posted almost 2 years ago. Dec 30, 2015 - 01:15 EST