Internet Peering Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
While some users are still experiencing difficulties, the majority of the peering issues look to have subsided. There still exists higher than usual internet congestion and latency occurring upstream of our services. We are continuing to monitor the situation and will open new incidents as necessary. #PALADINS #TRIBES #Xbox #PS4
Posted 11 months ago. Apr 17, 2016 - 01:48 EDT
Investigating
Users in some geographic locations are reporting degraded performance; we are investigating the root cause and working with our providers to resolve. There are widespread internet peering issues with certain ISPs that are impacting players from all regions on all non-mobile products. #SMITE #PALADINS #TRIBES #Xbox #PS4
Posted 11 months ago. Apr 16, 2016 - 23:15 EDT