Smite PC - Pausing Logins
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins on #SmitePC have been re-enabled; apologies for the inconvenience.
Posted 3 months ago. Mar 17, 2017 - 20:50 EDT
Identified
We are momentarily pausing logins on #SmitePC; logins will be re-enabled shortly; apologies for the inconvenience.
Posted 3 months ago. Mar 17, 2017 - 20:43 EDT
This incident affected: Smite PC - North America / Europe.