Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #PaladinsPC has been resolved.
Posted 7 months ago. Mar 22, 2017 - 12:11 EDT
Monitoring
A fix has been implemented and we are monitoring the results #PaladinsPC
Posted 7 months ago. Mar 22, 2017 - 11:26 EDT
Update
We are currently investigating this Paladins PC issue. #PaladinsPC
Posted 7 months ago. Mar 22, 2017 - 11:14 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 7 months ago. Mar 22, 2017 - 10:51 EDT
This incident affected: Paladins PC.