Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite XBOX incident has been resolved#smite
Posted over 1 year ago. Mar 31, 2016 - 16:45 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted over 1 year ago. Mar 31, 2016 - 16:33 EDT