Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins incident has been resolved#paladins
Posted 10 months ago. Jan 11, 2017 - 05:04 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 10 months ago. Jan 11, 2017 - 04:38 EST
This incident affected: Paladins PC.