Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#Paladins PC is returning to normal; game is stable; apologies for the inconvenience.
Posted 4 months ago. Apr 10, 2017 - 02:49 EDT
Monitoring
Emergency restart of #Paladins PC is complete; logins have been re-enabled; continuing to monitor.
Posted 4 months ago. Apr 10, 2017 - 02:32 EDT
Identified
we will be performing an emergency restart of #Paladins PC; game back shortly
Posted 4 months ago. Apr 10, 2017 - 02:17 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 4 months ago. Apr 10, 2017 - 02:06 EDT
This incident affected: Paladins PC.