Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 21 days ago. Apr 29, 2018 - 15:34 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 21 days ago. Apr 29, 2018 - 15:26 EDT
This incident affected: Smite Xbox - North America / Europe.