Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 7 months ago. Dec 19, 2016 - 12:19 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 7 months ago. Dec 19, 2016 - 12:06 EST
This incident affected: Paladins PC.