Smite PS4 Purchasing Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Jan 26, 2017 - 16:11 EDT
Identified
PSN is experiencing issues with their store services, which will cause users to problems with purchases on Smite PS4 #SmitePS4
Posted about 2 months ago. Jan 26, 2017 - 13:04 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted about 2 months ago. Jan 26, 2017 - 12:59 EDT
This incident affected: Smite PS4 - North America / Europe.