Pausing Logins
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins have been resumed on #Smite #PC
Posted 7 months ago. Feb 07, 2017 - 15:10 EST
Investigating
We will be pausing logins momentarily on #Smite #PC
Posted 7 months ago. Feb 07, 2017 - 14:45 EST
This incident affected: Smite PC - North America / Europe.