Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 6 months ago. Feb 12, 2017 - 22:45 EST
Update
We will be performing an emergency restart on #Smite #PC.
Posted 6 months ago. Feb 12, 2017 - 22:38 EST
Identified
We are currently investigating issues affecting #Smite on PC.
Posted 6 months ago. Feb 12, 2017 - 22:21 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 6 months ago. Feb 12, 2017 - 22:18 EST
This incident affected: Smite PC - North America / Europe.