Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PS4 incident has been resolved#smite
Posted about 1 year ago. Mar 31, 2016 - 16:44 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted about 1 year ago. Mar 31, 2016 - 16:33 EDT