Smite Xbox Pausing logins
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins have resumed for smite on xbox.
#SMITE
Posted about 1 year ago. Apr 11, 2016 - 20:55 EDT
Investigating
We will be pausing logins on xbox for a short amount of time.
Sorry for the inconvenience.
#SMITE
Posted about 1 year ago. Apr 11, 2016 - 20:45 EDT