Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE PC issue has been resolved; we are all-clear.
Posted 11 months ago. Jan 10, 2017 - 19:39 EST
Monitoring
#SMITE PC emergency restart complete; we are continuing to monitor.
Posted 11 months ago. Jan 10, 2017 - 18:59 EST
Identified
We are performing and emergency restart of #SMITE PC; game will be back to operational shortly.
Posted 11 months ago. Jan 10, 2017 - 18:32 EST
Investigating
We are currently looking into issues with SMITE PC. #SMITE
Posted 11 months ago. Jan 10, 2017 - 18:19 EST
Identified
We have identified an issue with #SMITE PC that is impacting player connections; we are working to resolve
Posted 11 months ago. Jan 10, 2017 - 18:19 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 11 months ago. Jan 10, 2017 - 18:12 EST
This incident affected: Smite PC - North America / Europe.