Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 9 months ago. Oct 06, 2016 - 02:39 EDT
Identified
XBL seems to be experiencing issues, Users may have issues login and staying connected to smite xbox.
http://downdetector.com/status/xbox-live #smite XBOX
Posted 9 months ago. Oct 05, 2016 - 23:06 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 9 months ago. Oct 05, 2016 - 22:41 EDT