Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This Smite PS4 incident has been resolved. #SMITEPS4
Posted about 2 months ago. May 07, 2017 - 17:33 EDT
Monitoring
A fix has been implemented and we are monitoring the results. #SMITEPS4
Posted about 2 months ago. May 07, 2017 - 17:07 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted about 2 months ago. May 07, 2017 - 16:50 EDT