Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE PC issues have been resolved; all systems normal.
Posted 2 months ago. Jan 13, 2017 - 02:32 EDT
Monitoring
#SMITE PC emergency restart complete; game is up; continuing to monitor.
Posted 2 months ago. Jan 13, 2017 - 01:55 EDT
Identified
#SMITE PC issues will require an emergency restart; game back shortly.
Posted 2 months ago. Jan 13, 2017 - 01:37 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 2 months ago. Jan 13, 2017 - 01:33 EDT
This incident affected: Smite PC - North America / Europe.