Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. Feb 08, 2017 - 15:18 EDT
Update
We are performing an emergency restart on Smite PC. #SMITE PC
Posted about 1 month ago. Feb 08, 2017 - 15:10 EDT
Identified
We are currently working on issues with Smite PC. #SMITE PC
Posted about 1 month ago. Feb 08, 2017 - 14:55 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 1 month ago. Feb 08, 2017 - 14:53 EDT
This incident affected: Smite PC - North America / Europe.