Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE PC has recovered; all systems normal.
Posted 3 months ago. Jan 22, 2017 - 06:18 EST
Monitoring
#SMITE PC has returned to operation post an emergency restart; game is open; continuing to monitor
Posted 3 months ago. Jan 22, 2017 - 05:59 EST
Identified
#SMITE PC is going down for an emergency restart; game back shortly
Posted 3 months ago. Jan 22, 2017 - 05:38 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 3 months ago. Jan 22, 2017 - 05:31 EST
This incident affected: Smite PC - North America / Europe.