Log in issues
Incident Report for Hi-Rez Studios, Inc
Resolved
All Platforms and All Games have returned to normal.
Posted almost 2 years ago. Dec 22, 2015 - 19:41 EST
Update
All Platforms and All Games are experiencing Log In Issues
Posted almost 2 years ago. Dec 22, 2015 - 19:14 EST
Investigating
We are Investigating
Posted almost 2 years ago. Dec 22, 2015 - 19:11 EST