Smite PC Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
#Smite PC issue fully resolved; game fully operational.
Posted 2 months ago. Jan 12, 2017 - 10:16 EDT
Monitoring
#Smite PC restart is complete; we are continuing to monitor.
Posted 2 months ago. Jan 12, 2017 - 09:38 EDT
Identified
#Smite PC will be restarted; game back up shortly.
Posted 2 months ago. Jan 12, 2017 - 09:28 EDT
This incident affected: Smite PC - North America / Europe.