Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issues with #SMITE #PS4 have been resolved.
Posted 7 months ago. May 08, 2017 - 21:17 EDT
Monitoring
A fix has been implemented for #SMITE #PS4 , and we are monitoring the results.
Posted 7 months ago. May 08, 2017 - 20:50 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 7 months ago. May 08, 2017 - 20:41 EDT
This incident affected: Smite PS4 - North America / Europe.