Smite PC Connection Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 10 months ago. Jan 31, 2017 - 17:18 EST
Investigating
We are currently investigating issues with Smite PC. #SMITE PC
Posted 10 months ago. Jan 31, 2017 - 17:02 EST
This incident affected: Smite PC - North America / Europe.