Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Xbox Live Services seem to be back to normal for Smite XBOX #smite
Posted about 1 year ago. Mar 05, 2016 - 13:55 EDT
Identified
Xbox Live was having issues with people being able to log in and create accounts, http://support.xbox.com/en-US/xbox-live-status?icid=furl_status #smite
Posted about 1 year ago. Mar 05, 2016 - 13:35 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 year ago. Mar 05, 2016 - 13:22 EDT