Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Paladins #PC has been resolved.
Posted 19 days ago. Jul 03, 2017 - 19:02 EDT
Monitoring
We have implemented a fix for the issue in #Paladins #PC and are monitoring the results.
Posted 19 days ago. Jul 03, 2017 - 18:45 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 19 days ago. Jul 03, 2017 - 18:23 EDT
This incident affected: Paladins PC.