Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This Paladins PC incident has been resolved. #PaladinsPC
Posted about 2 months ago. May 08, 2017 - 11:29 EDT
Monitoring
A fix has been implemented and we are monitoring the results. #PaladinsPC
Posted about 2 months ago. May 08, 2017 - 11:20 EDT
Update
We are currently investigating this issue. #PaladinsPC
Posted about 2 months ago. May 08, 2017 - 11:14 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 2 months ago. May 08, 2017 - 11:05 EDT