Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved#smite
Posted over 1 year ago. May 25, 2016 - 21:33 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted over 1 year ago. May 25, 2016 - 21:20 EDT