Smite-PC Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 year ago. Aug 10, 2016 - 17:44 EDT
Monitoring
We have addressed an issue with #Smite PC; we are recovering and should be back to normal soon.
Posted about 1 year ago. Aug 10, 2016 - 17:41 EDT
Investigating
We are currently working to restore Match Making functionality in #Smite.
Sorry for the inconvenience.
Posted about 1 year ago. Aug 10, 2016 - 17:16 EDT