Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The incident effecting #Paladins #PC has been resolved.
Posted 7 months ago. Apr 01, 2017 - 11:04 EDT
Identified
We have the identified the problems effecting matches from launching, we are continuing to monitor.
#PALADINS #PC
Posted 7 months ago. Apr 01, 2017 - 10:51 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 7 months ago. Apr 01, 2017 - 10:50 EDT
This incident affected: Paladins PC.