Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Smite PC has recovered #smite
Posted about 1 year ago. Mar 06, 2016 - 11:38 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 1 year ago. Mar 06, 2016 - 11:30 EDT