Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Issues with #SMITE #PS4 have been resolved.
Posted 6 months ago. May 09, 2017 - 23:04 EDT
Monitoring
A fix has been implemented and we are monitoring the results. #SmitePs4
Posted 6 months ago. May 09, 2017 - 22:37 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 6 months ago. May 09, 2017 - 22:22 EDT
This incident affected: Smite PS4 - North America / Europe.