Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This incident Hirez Games has been resolved#SMITE #Tribes #Paladins
Posted 12 months ago. Mar 31, 2016 - 16:44 EDT
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted 12 months ago. Mar 31, 2016 - 16:33 EDT