Smite PS4
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 2 months ago. May 15, 2018 - 10:08 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. May 15, 2018 - 09:44 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 2 months ago. May 15, 2018 - 09:29 EDT
Investigating
We are working on issues with Smite PS4
Posted 2 months ago. May 15, 2018 - 09:14 EDT
This incident affected: Smite (Smite PS4).