Smite; PC, Xbox. Paladins; PC and PS4 Possible Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue has been resolved and we are continuing to monitor.
Posted Sep 11, 2017 - 19:02 EDT
Monitoring
We are continuing to monitor the situation.
Posted Sep 11, 2017 - 17:55 EDT
Investigating
We are investigating.
Posted Sep 11, 2017 - 17:40 EDT
This incident affected: SMITE (SMITE PC, SMITE Xbox) and Paladins (Paladins PC, Paladins PS4).