Tribes PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This tribes incident has been resolved. #TRIBES
Posted 9 months ago. Feb 04, 2017 - 08:12 EST
Investigating
Automated services have detected a possible problem with #Tribes PC. We are investigating.
Posted 9 months ago. Feb 04, 2017 - 07:00 EST
This incident affected: Tribes Ascend.