Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 12 months ago. Dec 18, 2016 - 10:54 EST
Identified
We are working to restore some our core services.
We apologize for the inconvenience.
Posted 12 months ago. Dec 18, 2016 - 10:49 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 12 months ago. Dec 18, 2016 - 10:40 EST