Emergency PS4 Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 10 months ago. Jul 12, 2016 - 08:24 EDT
Identified
We will be restarting #Smite on #PS4.
Downtime Should be minimal.
Sorry for the inconvenience.
Posted 10 months ago. Jul 12, 2016 - 07:56 EDT