Smite Xbox Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
The Smite xbox restart has been completed.
#SMITE
Posted about 1 year ago. Apr 11, 2016 - 14:27 EDT
Investigating
We will be restarting the xbox environment to alleviate party issues.
Limited access will begin at 1:30 PM EST.
#SMITE
Posted about 1 year ago. Apr 11, 2016 - 13:10 EDT