Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issues with #SMITE #PC have been resolved.
Posted about 2 months ago. May 05, 2017 - 22:57 EDT
Monitoring
A fix for #SMITE #PC has been implemented, and we are monitoring the results.
Posted about 2 months ago. May 05, 2017 - 22:13 EDT
Identified
We are performing an emergency restart on #SMITE #PC
The game will be down briefly.
Posted about 2 months ago. May 05, 2017 - 22:05 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 2 months ago. May 05, 2017 - 21:55 EDT
This incident affected: Smite PC - North America / Europe.