Paladins emergency restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 7 months ago. Sep 17, 2016 - 09:49 EDT
Identified
We will be preforming an emergency restart of paladins in 10 min#paladins
Posted 7 months ago. Sep 17, 2016 - 08:32 EDT